magicJack and MagicJack Plus Support, Reviews, FAQs and Hacks Forum Index magicJack and MagicJack Plus Support, Reviews, FAQs and Hacks
magicJack and magicJack Plus Unofficial Technical Support. Your Magic Jack and Magic Jack Plus phone service information resource
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
***New Mods T5730 a Dual-Core 64-bit CPU & PCIe G-card
Goto page Previous  1, 2, 3 ... 46, 47, 48, 49  Next
 
Post new topic   Reply to topic    magicJack and MagicJack Plus Support, Reviews, FAQs and Hacks Forum Index -> Using magicJack on a Thin Client
View previous topic :: View next topic  
Author Message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Thu Mar 17, 2016 4:34 am    Post subject: Reply with quote

WinSCP - Its just an FTP / SFTP / SSH client which is a free thing https://winscp.net/eng/index.php It also my chosen file explorer when looking at an iDevice file system for what ever crazy reason I have for that day xD - you still need to be able to connect via IP with WinSCP though so I'd guess in dire consequence you'll still need the USB / serial mix

it does sound easy Neutral especialy with no soldering needed xD

not bad if it works well (assuming apple allow it through their evil app filters :p ) I guess you can always side load with xcode

I'd be running the nano as a hotspot (even with its own SSID if need be) just for that room on the weekend I manage to do a cat5e run to her room and made up a couple of split cat5e cables to I'm able to run 2x100mb down 1 cat5e run (this makes sense for me since my terrible sky router only supports 100mb ethernet any way they're still in the late 90 early 2000's with their tech -.- )

Hey if you’re willing you should be able to run power and Ethernet down one self made network cable if you’re also willing to cup up USB cabled too :p for 100mb you only need pins 123&6 so you could send power down the cables in 457&8 (blue pair brown pair usually) hey this could just be a useful sort of cable to have anyway Very Happy

and another great use for the little hootoo - can the camera be set to record to a USB storage device.. oh wait only 1 USB port (unless you can use a USB hub (?) I've got a WIF Trendnet day/night cloud camera but the infrared LED reflected on the glass it was sat behind so I ended up setting up outside - i think It my of succumbed to moisture Sad its not responding to ping at the moment but then I've not really sat down and looked at it too much



Code:
Thu Mar 17 09:03:54 2016 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Mar 17 09:03:54 2016 TLS Error: TLS handshake failed
Thu Mar 17 09:03:54 2016 SIGUSR1[soft,tls-error] received, process restarting


Still on this TLS key negotiation fialing :/
https://openvpn.net/index.php/open-source/faq/79-client/253-tls-error-tls-key-negotiation-failed-to-occur-within-60-seconds-check-your-network-connectivity.html
it could be windows filrewall stuff or just My HooToo still not listening on my chosen port :p
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
Google
AdSense





PostPosted: Thu Mar 17, 2016 4:34 am    Post subject: Magicjack support, tips, tricks, and hacks

Back to top
momo
Dan Should Pay Me


Joined: 26 Aug 2008
Posts: 541

PostPosted: Thu Mar 17, 2016 5:09 am    Post subject: Reply with quote

985ach wrote:
WinSCP - Its just an FTP / SFTP / SSH client which is a free thing https://winscp.net/eng/index.php It also my chosen file explorer when looking at an iDevice file system for what ever crazy reason I have for that day xD - you still need to be able to connect via IP with WinSCP though so I'd guess in dire consequence you'll still need the USB / serial mix

This windows App sounds like the Easy FTP Pro App I have for the iOS
It does much of the same thing with file transfers, and he'll be adding the video/audio player, and photo-viewer functions to it for viewing directly from the DLNA file server.

985ach wrote:
it does sound easy Neutral especialy with no soldering needed xD

Well...it sounds easy, but I haven't tried it yet to make sure...but wingspinner said it worked for him, but someone else tried it, and said he had trouble making it work...so I'd need to see for myself, to be sure. Smile

985ach wrote:
not bad if it works well (assuming apple allow it through their evil app filters :p ) I guess you can always side load with xcode

Are you referring to the Easy FTP Pro App?
Because the developer is mostly finished with completing the direct from SMB (DLNA) video/audio player, and photo viewer, and will add the FXP functions to it soon, ...Apple will allow it, as with all the other functions it already has.

985ach wrote:
I'd be running the nano as a hotspot (even with its own SSID if need be) just for that room, on the weekend I manage to do a cat5e run to her room and made up a couple of split cat5e cables to I'm able to run 2x100mb down 1 cat5e run (this makes sense for me since my terrible sky router only supports 100mb ethernet any way they're still in the late 90 early 2000's with their tech -.- )

So if you ran cables to her room, do you still need the repeater function of the HooToo?

985ach wrote:
Hey if you’re willing you should be able to run power and Ethernet down one self made network cable if you’re also willing to cup up USB cabled too :p for 100mb you only need pins 123&6 so you could send power down the cables in 457&8 (blue pair brown pair usually) hey this could just be a useful sort of cable to have anyway Very Happy

Yeah...this power over Ethernet is getting very popular

985ach wrote:
and another great use for the little hootoo - can the camera be set to record to a USB storage device.. oh wait only 1 USB port (unless you can use a USB hub (?) I've got a WIF Trendnet day/night cloud camera but the infrared LED reflected on the glass it was sat behind so I ended up setting up outside - i think It my of succumbed to moisture Sad its not responding to ping at the moment but then I've not really sat down and looked at it too much

With the OpenWRT on it, you can install a USB Hub package, so YES, it's possible to use more than one USB device on the HooToo, and the LuCI MJPEG interface already supports saving photos, and I also think videos too, to a hard drive or flash drive file. Smile

Also, any USB camera that works with Linux will work on the HooToo with OpenWRT.

*** EDITED ***
I saw your edited mention of your HooToo VPN not seeing your chosen port.
Did you add the 'fix' that the other OpenWRT post mentioned for the port change other than port 22 ...?

I mentioned it in this post...
http://www.phoneservicesupport.com/post85324.html#85324
_________________
HP T5730 - AMD Turion 64 x2 Dual-Core 2.4GHz CPU
(TMDTL68HAX5DM)
320GB WD 2.5" H.D. / 2GB RAM
(Windows 8.1 Pro 64-bit)
EVGA GeForce 7600 GT PCIe x16 card, (in x1 speed)
New 12vdc 16 amp (192w) PSU
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Thu Mar 17, 2016 6:16 am    Post subject: Reply with quote

momo wrote:

This windows App sounds like the Easy FTP Pro App I have for the iOS
It does much of the same thing with file transfers, and he'll be adding the video/audio player, and photo-viewer functions to it for viewing directly from the DLNA file server.

Yeh I guess it’s just another FTP app but without the audio / video play back Wink

momo wrote:

Well...it sounds easy, but I haven't tried it yet to make sure...but wingspinner said it worked for him, but someone else tried it, and said he had trouble making it work...so I'd need to see for myself, to be sure. Smile

Good luck when you go and take the plunge with that one ^__^
momo wrote:

Are you referring to the Easy FTP Pro App?
Because the developer is mostly finished with completing the direct from SMB (DLNA) video/audio player, and photo viewer, and will add the FXP functions to it soon, ...Apple will allow it, as with all the other functions it already has.

Yes just sort of mocking Apples “iron curtain” approach to things and being strict and all that – though It’s good to hear they’re still refusing to create a back door to their devices for the FBI to go snooping Very Happy

momo wrote:
So if you ran cables to her room, do you still need the repeater function of the HooToo?

Yeah to cover her wireless devices too – We’ve got her PS3 plugged directly into the network now.
I’m going to take a guess that it my fusebox and a mass of electrical wiring that’s causing interference for the wireless signal in her room cause she’s not even 4 meters away from the wireless router…
momo wrote:

With the OpenWRT on it, you can install a USB Hub package, so YES, it's possible to use more than one USB device on the HooToo, and the LuCI MJPEG interface already supports saving photos, and I also think videos too, to a hard drive or flash drive file. Smile


Also, any USB camera that works with Linux will work on the HooToo with OpenWRT.
[/quote]
There goes £40 very quickly on new hootoo devices :p
momo wrote:

*** EDITED ***
I saw your edited mention of your HooToo VPN not seeing your chosen port.
Did you add the 'fix' that the other OpenWRT post mentioned for the port change other than port 22 ...?

I mentioned it in this post...
http://www.phoneservicesupport.com/post85324.html#85324


I’ve not done that but OpenWRT SSH still responds to port 22 as expected so that’s all good – it’s my chosen OpenVPN port so I need to work out and get my OpenVPN to run the service on the right port – I wonder where the config is located on the hootoo for openVPN – off for a hunt!
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Thu Mar 17, 2016 6:33 am    Post subject: Reply with quote

wow.. theres not alot to my "opencpn-myvpn.conf"
thats located /var/etc/
no files located in /etc/openvpn/

Code:

persist-tun
tls-server
ca /etc/openvpn/ca.crt
cert /etc/openvpn/my-server.crt
dev tap_myvpn
dh /etc/openvpn/dh2048.pem
key /etc/openvpn/my-server.key
mode server
port <MYPORT>
proto udp
verb 3
push route-gateway dhcp


:S
found another location after re-reading a link from an earlier page:

mine
Code:

config openvpn 'myvpn'
   option enabled '1'
   option verb '3'
   option port 'MYPORT'
   option proto 'udp'
   option dev 'tap_myvpn'
   option mode 'server'
   option tls_server '1'
   option persist_tun '1'
   option puch 'route-gateway dhcp'
   option push 'route-gateway dhcp'
   option ca '/etc/openvpn/ca.crt'
   option cert '/etc/openvpn/my-server.crt'
   option key '/etc/openvpn/my-server.key'
   option dh '/etc/openvpn/dh2048.pem'

this post: https://forum.openwrt.org/viewtopic.php?id=35021
Code:

config 'openvpn' 'samplevpnconfig'
        option 'enable' '1'
        option 'port' '1194'
        option 'proto' 'udp'
        option 'dev' 'tun'

        option 'client_to_client' '1'
        option 'keepalive' '10 120'
        option 'comp_lzo' '1'
        option 'persist_key' '1'
        option 'persist_tun' '1'
        option 'verb' '3'
        option 'mute' '20'
        option 'ifconfig_pool_persist' '/tmp/ipp.txt'
        option 'status' '/tmp/openvpn-status.log'
        option 'ca' '/etc/openvpn/ca.crt'
        option 'cert' '/etc/openvpn/server.crt'
        option 'key' '/etc/openvpn/server.key'
        option 'dh' '/etc/openvpn/dh1024.pem'

        option 'server' '172.16.0.0 255.255.255.0'  #this should be on a completely different subnet than your LAN
        list 'push' 'route 192.168.1.0 255.255.255.0' #this should MATCH your current LAN info
        list 'push' 'dhcp-option DNS 192.168.1.254' #this should MATCH your current LAN info
        list 'push' 'dhcp-option DOMAIN 192.168.1.254' #this should MATCH your current LAN info
        list 'push' 'redirect-gateway'


So I may config mine the same (chaning the appropirate) whilst backing up too xD

I've just upset luci - it's not talking to me any more on 192.168.0.222 :/ and my open vpn port is still closed so it's not going to respond to a connection there.
nuts going to have to plug the hootoo direct into my lappy again later and see if it serving DHCP IPs

still no life from a remote location - I suspect I've messed up the network configuration someway

else
START OVER Sad Sad Sad Sad Sad Sad Sad Mad
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Thu Mar 17, 2016 10:40 am    Post subject: Reply with quote

you know what i need to do.. set myself up a router that'll access the internet via a proxy so I can do stuff my my hootoo with out having to remote home to do it

I wonder if my DD-WRT router can do that - I'll have to find the power supply for it at least then when i screw up I can stright away start going back to defaults :p
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
momo
Dan Should Pay Me


Joined: 26 Aug 2008
Posts: 541

PostPosted: Thu Mar 17, 2016 1:48 pm    Post subject: Reply with quote

985ach wrote:
you know what i need to do.. set myself up a router that'll access the internet via a proxy so I can do stuff my my hootoo with out having to remote home to do it

I wonder if my DD-WRT router can do that - I'll have to find the power supply for it at least then when i screw up I can stright away start going back to defaults :p


I just noticed you may have added the 'list' word in your config, if you followed the sample config you listed in the code sample you quoted in your other post above.

...kelxon10995 in the #20 post of the thread at ... https://forum.openwrt.org/viewtopic.php?id=35021
...mentioned with Chaos Calmer 15.05 found it can't use the word 'list' in the config with CC 15.05 ...it stops the DNS lookup from working...


*** the quote from that threads #20 post ***

You may have the same or similar issue to what I have. Following this guide worked perfectly fine in Barrier Breaker, but in Chaos Calmer, the DNS lookup is not working, making access to Internet and local LAN devices inaccessible using device names or URL.

To resolve this issue, in /etc/config/openvpn, any route or DHCP options you're pushing to the vpn client, make sure to remove the "list" wordings, like:
push "route 192.168.1.0 255.255.255.0" #this should MATCH your current LAN info
push "dhcp-option DNS 192.168.1.1" #this should MATCH your current LAN info
push "dhcp-option DOMAIN LOCALDOMAIN.LAN" #this should MATCH your current LAN info
push redirect-gateway lan def1

This seems to resolve the issue for me in Chaos Calmer.


985ach wrote:
momo wrote:
So if you ran cables to her room, do you still need the repeater function of the HooToo?

Yeah to cover her wireless devices too – We’ve got her PS3 plugged directly into the network now.
I’m going to take a guess that it my fusebox and a mass of electrical wiring that’s causing interference for the wireless signal in her room cause she’s not even 4 meters away from the wireless router…

If she's only around 12 feet away and has issues with wireless from the home router, it may still affect her wireless connection from the HooToo as well.
If electrical interference is causing it all.

985ach wrote:
momo wrote:

With the OpenWRT on it, you can install a USB Hub package, so YES, it's possible to use more than one USB device on the HooToo, and the LuCI MJPEG interface already supports saving photos, and I also think videos too, to a hard drive or flash drive file. Smile

Also, any USB camera that works with Linux will work on the HooToo with OpenWRT.

There goes £40 very quickly on new hootoo devices :p

Ha Ha... Welcome to the HooToo addiction club... Rolling Eyes Razz Laughing Wink Very Happy Mr. Green
_________________
HP T5730 - AMD Turion 64 x2 Dual-Core 2.4GHz CPU
(TMDTL68HAX5DM)
320GB WD 2.5" H.D. / 2GB RAM
(Windows 8.1 Pro 64-bit)
EVGA GeForce 7600 GT PCIe x16 card, (in x1 speed)
New 12vdc 16 amp (192w) PSU
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Fri Mar 18, 2016 5:17 am    Post subject: Reply with quote

that'll learn me not to read on properly...

GOOD NEWS!
HooToo was still DHCPing but the WAN port setting too presidence over the LAN port so I ended up with 10.x.x.x or 172.16.x.x ips (depending on which config I used) so no reset needed Very Happy

though I did have to remore the WAN settings from the configs and then log into the LuCI gui to re connect the lan to get my normal 192.168.0.222 ip address

I did change all my configs while I was there back to the "default" ones I had but I have now removed the word 'list' and the surrounding '' marks from the word push
I think introduce configes one by one and work out what needed to be done with the LAN / WAN config

I'd assume they need to be bridged too or maybe a virtual switch needs to be running (?)

if the HooToo is in her room also opposite side of the room and above to where the bulk electrical wiring is it should be okay as a small personal hotspot though?

stop giving me an excuse not to buy another one Wink :p
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
momo
Dan Should Pay Me


Joined: 26 Aug 2008
Posts: 541

PostPosted: Fri Mar 18, 2016 6:13 am    Post subject: Reply with quote

985ach wrote:
that'll learn me not to read on properly...

GOOD NEWS!
HooToo was still DHCPing but the WAN port setting too presidence over the LAN port so I ended up with 10.x.x.x or 172.16.x.x ips (depending on which config I used) so no reset needed Very Happy

though I did have to remore the WAN settings from the configs and then log into the LuCI gui to re connect the lan to get my normal 192.168.0.222 ip address

I did change all my configs while I was there back to the "default" ones I had but I have now removed the word 'list' and the surrounding '' marks from the word push
I think introduce configes one by one and work out what needed to be done with the LAN / WAN config

I'd assume they need to be bridged too or maybe a virtual switch needs to be running (?)

if the HooToo is in her room also opposite side of the room and above to where the bulk electrical wiring is it should be okay as a small personal hotspot though?

stop giving me an excuse not to buy another one Wink :p


I'm so glad I mentioned the 'list' word change...
Good to know it helped.

Very Happy if the HooToo will be in her room ...yes of course it should work very well.
Of course though the RF radiation will cook her brain.... No No...just joking. Shocked Razz

You know, you may even be able to keep the original HooToo firmware for that. This was what it was originally made for.
Especially if you're going to have an Ethernet cable near-by her room, linked to your main router,
...it would be as if she was in a hotel room with just wired access and no WiFi.
So in this case, you may not even need to put OpenWRT on it...unless you want more security and the LuCI firewall control.

Hey...speaking of the firewall... Maybe you're also forgetting to adjust that for your OpenWRT VPN setup, and that's maybe giving you the issues you're having now, if nothing else in the configs are doing it.

I remember reading that the firewall is tricky setting up when using the OpenVPN... I'll see if I can find the post mentioning it, but while I was looking ...

...I found an OpenWRT LuCI Firewall White-List Example at the forum, and put it on my MoMo imgur site for easy viewing, to get an idea how to manipulate the LuCI interface that creates it.

Looking at it, I think I like this White-List idea better, rather than making a Black-List.
This way EVERYTHING is already blocked, except for the bits you want to be allowed IN.

https://i.imgur.com/g4tj7uv.jpg

------
EDIT
------

I found the conversation about the firewall.
Rather than post the link...
...Here's the entire text of it...
Maybe you can find something in that conversation to help your setup.


Hi, thanks for the great write up - followed with ease. I have one issue - when I connect from the internet 3g or another internet line I am authenticated & the openvpn client says its connected, however I cant connect to any of my LAN machines I can ping the address of my router, but not my server and RDP wont connect... I'm thinking it's an issue with the firewall, the file is as you described in your article... any ideas?
config zone
option input 'ACCEPT'
option forward 'REJECT'
option output 'ACCEPT'
option name 'VPN'
option network 'VPN'
config rule
option target 'ACCEPT'
option src 'lan'
option dest 'VPN'
option name 'LAN->VPN'
config rule
option target 'ACCEPT'
option src 'VPN'
option dest 'lan'
option name 'VPN->LAN'
config rule
option target 'ACCEPT'
option src 'wan'
option name 'OpenVPN'
option proto 'udp'
option dest_port '1194'

***UPDATE***
I think this is to do with bridging traffic between the VPN interface and the local LAN one - I enabled a bridge across eth0.1 & VPN, rebooted but still no joy... any ideas?

Try the following, in /etc/firewall.user or luci>firewall>custom rules:
###OPENVPN PASS-THROUGH ENABLE RULES###
iptables -t nat -A prerouting_wan -p udp --dport 11944 -j ACCEPT
iptables -A input_wan -p udp --dport 11944 -j ACCEPT
iptables -I INPUT -i tun+ -j ACCEPT
iptables -I FORWARD -i tun+ -j ACCEPT
iptables -I OUTPUT -o tun+ -j ACCEPT
iptables -I FORWARD -o tun+ -j ACCEPT
----

I can not get open VPN working correctly i followed thes steps but i can still not get it working. it looks like it is setup and the keys created but does not seem like it is getting through the firewall or bridge I have and bridged wireless and vlan eth0.1 and it seems ok just the client will sit on the other end trying to always connect but i get no logs on the router side to say the port was blocked
I am using wndr3700V2 and openwrt 12.09

By the way if i do a port scan it does show it is listening so it leads me to belive the Firewall or Routing is not working. on the firewall logs it never seems to see anyting come over the VPN side and port 1194

Maybe you can post the text of your files that need edited in case there is junk in ours that is blocking something.
----

Thanks for great HowTo... After many days of trying to get it working i finally get it.
I could log in and see routers ip through vpn, but i couldn't get over to the internet (no matter what tutorial did i use).

To all, who can connect, but cant access internet:
after i put these lines to /etc/config/firewall and reboot the router, i could finally get through vpn to internet

config 'forwarding'

option 'src' 'VPN'
option 'dest' 'wan'

Here my config files, if some1 interested:

/etc/config/firewall

config 'forwarding'
option 'src' 'VPN'
option 'dest' 'wan'
config 'zone'
option 'name' 'VPN'
option 'input' 'ACCEPT'
option 'output' 'ACCEPT'
option 'forward' 'REJECT'
config 'rule'
option 'target' 'ACCEPT'
option '_name' 'lantovpn'
option 'src' 'lan'
option 'dest' 'VPN'
config 'rule'
option 'target' 'ACCEPT'
option '_name' 'vpntolan'
option 'src' 'VPN'
option 'dest' 'lan'
config 'rule'
option 'target' 'ACCEPT'
option '_name' 'openVPN'
option 'src' 'wan'
option 'proto' 'udp'
option 'dest_port' '1194'

_________________
HP T5730 - AMD Turion 64 x2 Dual-Core 2.4GHz CPU
(TMDTL68HAX5DM)
320GB WD 2.5" H.D. / 2GB RAM
(Windows 8.1 Pro 64-bit)
EVGA GeForce 7600 GT PCIe x16 card, (in x1 speed)
New 12vdc 16 amp (192w) PSU
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Fri Mar 18, 2016 8:56 am    Post subject: Reply with quote

ahh awesome - cheers for all that

I'll check out the imgur.com link later (home laptop has been turned off by someone today :/ and the site is filters on my work place internet)

if it is as simple as the firewall I could just let everything through... I am behind another firewall anyway? I know its not the safest and the more firewall the better xD one way or another opening that up would tell me if the firewall is blocking me or not....

mmm wireless radiation - it's cool everytime we use out iDevices we're steping closer to a medium rare brain :p
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Wed Mar 23, 2016 4:25 am    Post subject: Reply with quote

howdy!
not done much recently on the little HooToo, but in other news I fount my "Sky Wireless Booster" (Sky SB601 // Rebranded Airties 4400) (Sky were giving this away free due to how terrible their routers are as standard (or thats what I'm saying anyway))

Anyway it's terrible as it is - it just a wireless repeater taking 50% of your wireless bandwith o wahts that 27mbps remain for other devices (urgh)

but with out reading this fully https://forum.openwrt.org/viewtopic.php?id=48201 maybe I could make it useful Very Happy

Just finished reading looks like things halted April 2014

It also looks like it could run in access point mode - which would be nice just a shame that Sky have restricted the firmware so much Sad Invalid signature when attempting to flash stock firmware via the GUI

in other news to do with this little wireless repeater its 5V 1A- so I've changed the 240v adapter for a USB connector runs nicley so I'll be able to pick up power from a devices with a USB socket xD
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
momo
Dan Should Pay Me


Joined: 26 Aug 2008
Posts: 541

PostPosted: Wed Mar 23, 2016 5:02 pm    Post subject: Reply with quote

Hi 985ach
Glad you're O.K.
I thought you had the 'ear-dizzy' thing again when not hearing from you for awhile.

I see you found another old toy.. Smile

I'm sure there's a way to flash the stock firmware to it...
either with a separate programmer, or maybe someone on the OpenWRT forum may have a fix...

Anyway... if you'd like to 'take-a-break' from the HooToo... I understand Very Happy
Cool

Nice having you here...bye.
_________________
HP T5730 - AMD Turion 64 x2 Dual-Core 2.4GHz CPU
(TMDTL68HAX5DM)
320GB WD 2.5" H.D. / 2GB RAM
(Windows 8.1 Pro 64-bit)
EVGA GeForce 7600 GT PCIe x16 card, (in x1 speed)
New 12vdc 16 amp (192w) PSU
Back to top
View user's profile Send private message
momo
Dan Should Pay Me


Joined: 26 Aug 2008
Posts: 541

PostPosted: Fri Mar 25, 2016 12:56 am    Post subject: Reply with quote

Hey everyone... One of the original members at the OpenWRT forum, who made an OpenVPN installation Tutorial Post, came back, and posted how to do it specifically for the HooToo TM02. Smile. How cool is that...?
I haven't tested this yet...
...hahaha...but I've put it here for those who'd want to try.

One extra bit I'm adding now are the two actual files associated with the TM02
in the directory the Original Poster mentions at the thread below.

*** RECENT ADDITIONAL IMPORTANT INFO ***

-------
There are more posts dealing with this VPN install and my below concerns, ...also mentioned in the original posters thread starting at...
https://forum.openwrt.org/viewtopic.php?pid=316605#p316605

Many of the issues mentioned below, here, are addressed by the original poster (600cc) ...so be sure to view that post often to see any changes or additions to the thread regarding all this.
He assures he has not had any of the issues with the TM02.

-------

His post links to the folder that is from the 15.05.1 folder, but that folder is said to have defective builds that had issues with old kernel versions being added to newer builds, creating kernel hangs during boot, and package mis-matches when installing additions.

See this thread mentioning it...
https://forum.openwrt.org/viewtopic.php?id=63426

The known original stable build from September 14th 2015 is at

https://downloads.openwrt.org/chaos_calmer/15.05/ramips/rt305x/

https://downloads.openwrt.org/chaos_calmer/15.05/ramips/rt305x/packages/

But, within that above link'd 'Packages' folder, I see the 'Base' folder dated March 2nd 2016,
and the 'packages' folder dated March 1st 2016 , so I don't know if those folders are also affected being the others are dated from Sept 2015.

I think it may be best to wait until this all gets straightened out at the OpenWRT forum... I wish I could try this now, but I'm still waiting to test another developers iOS App update, with the DLNA / Samba file server, and need my last 3rd TM02 with the factory firmware on it to do this.

If any of you still want to try... I'm sure the configuration for the OpenVPN is still valid that the original poster mentions...
...this other kernel issue happened when the servers were down at the OpenWRT site, and the build-BOTs created firmware files with mixed kernels by accident...

the original 15.05 files are as follows


I think the ...
https://downloads.openwrt.org/chaos_calmer/15.05/ramips/rt305x/openwrt-15.05-ramips-rt305x-ht-tm02-squashfs-sysupgrade.bin
... is the main sysupgrade file if you've already replaced the HooToo factory firmware.

There's another one...
https://downloads.openwrt.org/chaos_calmer/15.05/ramips/rt305x/openwrt-15.05-ramips-rt305x-ht-tm02-initramfs-uImage.bin
... called initramfs-uImage ... I don't know what that one is, ...
... but the larger file size one is the sysupgrade file...and seems more complete.

--------

@985ach
I hope you'll see this..!
If anyone deserves to see the final solution...IT'S YOU ..! Mr. Green

You worked so hard to get it going, and burned yer little brain out...poor thing...! Cool

--------

OpenVPN on HooToo TM02 TripMate nano router

In original thread... From the original poster Tutorial ...
https://forum.openwrt.org/viewtopic.php?id=57090

At new post specifically for TM02 VPN Config and Setup ...
https://forum.openwrt.org/viewtopic.php?pid=316563#p316563

The complete copied text of post, and full configs in 'code' boxes...
...all I did was format it better for text reading here or copied to a NotePad style App...



Well, that took less time than I thought it might. Smile
My HooToo TripMate Nano TM02 (or whatever it's called) now has Chaos Calmer 15.05.1 installed from...

https://downloads.openwrt.org/chaos_calmer/15.05.1/ramips/rt305x/

...and OpenVPN is running and routing successfully.

Here's how I did it. All of the following steps were carried out on the TM02's command line, either via Telnet or SSH. I didn't bother using the web GUI for anything apart from setting a new IP address.


** Assumptions: **

- You know how to use Telnet and/or SSH, and have a suitable Telnet/SSH client on your computer.

-You know your way around the Linux command line, the hierarchical file system, and know how to edit text files with vi or nano.

-You know what IP address scheme is used for your own network, and how to allocate appropriate IP addresses for new devices on your network.

-You know how to install and configure OpenVPN as a server on a device/computer with multiple NICs - this is not an OpenVPN tutorial, but rather a recipe for getting OpenVPN to work on a device with a single NIC.

-You know how to install and configure OpenWRT - this is not an OpenWRT tutorial.


1. Install Chaos Calmer 15.05.1. Reset the device to factory defaults. Connect to the device at 192.168.1.1. You can use either the web GUI or Telnet (or SSH after you set a root password).
I connected a laptop directly to the TM02's ethernet port and made the necessary IP address changes in the next step before connecting the TM02 to the rest of my network.

2. Give the device a new hostname, unbridge the LAN interface so that it's wired-only, and give the LAN interface a valid static IP address configuration for your network (192.168.1.1 could possibly conflict with your edge router, if you're not careful). Finally, disable the DHCP server on the LAN interface.
It's probably not necessary to unbridge the LAN network, but if you're not using the wireless radio then why include it in the configuration?

3. Connect the TM02 to your network.
If you don't disable the DHCP server on the LAN interface in step 2, there could be a conflict between the TM02 and your real DHCP server.

4. Install the packages openvpn-openssl and openvpn-easy-rsa (and, optionally, luci-app-openvpn)
luci-app-openvpn is only needed if you want to manage the VPN from the web GUI. I don't bother; the command line is fine for my needs.

5. Edit /etc/easy-rsa/vars to contain the details you want. Keep KEY_SIZE at 2048 or higher for security.
Near the bottom of /etc/easy-rsa/vars are some lines you can personalise (KEY_COUNTRY, KEY_PROVINCE, etc.) As long as they're not blank, they can contain pretty much anything you choose.

6. Create the necessary CA, keys, and certificates. I also elected to create a TLS key and a CRL, for added security.
6.1 build-ca
6.2 build-key-server server
6.3 build-key-pkcs12 dummy
6.4 revoke-full dummy
6.5 build-key-pkcs12 client1
6.6 build-key-pkcs12 client2
6.7 build-dh
6.8 openvpn --genkey --secret /etc/easy-rsa/keys/ta.key
6.3 creates a dummy certificate, 6.4 creates the CRL by revoking the dummy certificate, and 6.8 creates the TLS key. All three are optional. If you elect to include them, you must also ensure that appropriate lines are included in /etc/config/openvpn

6. Copy the required certificates and keys from /etc/easy-rsa/keys to /etc/openvpn.
At a minimum, this should be ca.crt, server.crt, server.key, and dhXXXX.pem, where XXXX is your key size from step 5. You should also copy ta.key and crl.pem if you've decided to include them.

7. Edit (or create) the file /etc/config/openvpn to contain values suitable for your network and certificate/key files created in step 5.
This file controls how the OpenVPN server will behave. If there are any mistakes, the OpenVPN process will fail to start.

8. Start the OpenVPN service by issuing the command /etc/init.d/openvpn start. Check the output of the ps command to verify that there is an openvpn process running. If there isn't, check the contents of /tmp/openvpn.log for more information.
The most likely cause of any failure is a spelling mistake in the configuration file, or a missing certificate/key file. Once you get the openvpn process running successfully, it will create a new virtual network interface called 'tun0', which will be used in the next few steps.

9. Create a new WAN interface, bound to the physical interface eth0 and without any protocol assigned.
This is necessary for a later step involving the firewall. For this to work properly, you must have a WAN and LAN interface defined. This is where I slipped up the first time around at the top of this thread.

10. Create a new VPN interface, bound to the virtual interface tun0 and also without any protocol assigned.
This is also necessary for the firewall. Later in this process you will configure the firewall to allow traffic between the WAN, LAN, and VPN.

11. Configure the firewall zone settings to allow traffic from the LAN Zone to the WAN and VPN Zones.

12. Configure the firewall zone settings to allow traffic from the VPN Zone to the LAN and WAN Zones.
It is not necessary to allow any traffic from the WAN Zone; that should remain unchanged from the standard default configuration.

13. Configure the firewall traffic rules to allow inbound UDP traffic from the WAN to port 1194 on the device.
By default, inbound traffic is dropped or rejected. Allowing inbound traffic to UDP 1194 on the WAN interface allows inbound VPN clients to connect.

14. Configure the network's edge (Internet) router to forward (NAT) inbound traffic for UDP port 1194 to the HooToo device.

My edge router also runs OpenWRT, which makes things easier!

Notes:

This can also work if the TM02's LAN interface is set to DHCP, but it requires additional work to get dynamic port forwarding set up on your edge router. For now, stick to static IP until you're comfortable you've got it working.

build-dh takes a very long time to run, especially if you configure a high value for KEY_SIZE in /etc/easy-rsa/vars. The TM02 does not have a fast CPU, so be prepared to wait. And wait. Go and make a cup of tea, or watch a television show.

All of the key-generation commands can be run on the TM02, but I highly recommend running build-dh on a proper computer with a decent CPU and then copying the resulting .PEM file from your computer to the TM02.

I used a KEY_SIZE of 512 strictly for testing, because it's small enough for the TM02 to run build-dh reasonably quickly. However, a key size of 512 is not secure. The default KEY_SIZE is 2048, which should be secure enough for now. If you're feeling paranoid, you can increase KEY_SIZE to 4096. Note: a higher key size increases the client negotiation and connection time.

You can generate all the certificates and keys on a separate computer and just copy the necessary files to the TM02; you don't have to generate any certs or keys directly on the device.

Pay close attention when generating the certificates. You can press Return to skip past many of the prompts, but there are some prompts you must answer with a "y".

You do not have to specify an export password when generating the PKCS12 certificates, but it is highly recommended that you do so. The export password is what keeps the key secure. Without it, anyone can use the certificate if they get hold of it.

Changes you make to the files in /etc/config can be seen in the web GUI and in the console uci command, and vice-versa: any changes you make with uci or the web GUI will be reflected in the contents of /etc/config.

You can monitor the progress of any client connection attempts if you issue the command tail -f /tmp/openvpn.log on the TM02's command line. Press Ctrl-C when you want to stop monitoring.

I have included my TM02's configuration files here:

/etc/config/system

config system
option hostname 'tm02'
option zonename 'UTC'
option timezone 'GMT0'
option conloglevel '8'
option cronloglevel '8'

config timeserver 'ntp'
option enabled '1'
list server 'ntp1.npl.co.uk'
list server 'ntp2.npl.co.uk'
list server '0.uk.pool.ntp.org'
list server '1.uk.pool.ntp.org'
list server '2.uk.pool.ntp.org'
list server '3.uk.pool.ntp.org'

config led 'led_eth'
option name 'Ethernet'
option sysfs 'ht-tm02:green:lan'
option dev 'eth0'
option trigger 'netdev'
option mode 'link tx rx'

config led 'led_wifi_led'
option name 'wifi'
option sysfs 'ht-tm02:blue:wlan'
option dev 'wlan0'
option trigger 'netdev'
option mode 'link tx rx'


/etc/config/network - change the options under "config interface 'lan'" to match your network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.20.23'
option netmask '255.255.255.0'
option gateway '192.168.20.1'
option broadcast '192.168.20.255'
option dns '192.168.20.1'

config interface 'vpn'
option ifname 'tun0'
option proto 'none'

config interface 'wan'
option ifname 'eth0'
option proto 'none'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '0'


/etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option ignore '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'


/etc/config/firewall

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option drop_invalid '1'
option forward 'DROP'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'

config zone
option name 'wan'
option output 'ACCEPT'
option masq '1'
option mtu_fix '1'
option network 'wan'
option input 'DROP'
option forward 'DROP'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config zone
option input 'ACCEPT'
option forward 'DROP'
option output 'ACCEPT'
option name 'vpn'
option network 'vpn'

config forwarding
option dest 'lan'
option src 'vpn'

config forwarding
option dest 'wan'
option src 'vpn'

config forwarding
option dest 'vpn'
option src 'lan'

config rule
option target 'ACCEPT'
option src 'wan'
option proto 'udp'
option dest_port '1194'
option name 'OpenVPN'


/etc/config/openvpn

package openvpn

#################################################
# Sample OpenVPN 2.0 uci config for #
# multi-client server. #
#################################################

config openvpn server

# Set to 1 to enable this instance:
option enabled 1

option port 1194
option proto udp
option dev tun

option ca /etc/openvpn/ca.crt
option cert /etc/openvpn/server.crt
option crl_verify /etc/openvpn/crl.pem
option dh /etc/openvpn/dh512.pem
# These files should be kept secret:
option key /etc/openvpn/server.key
option tls_auth "/etc/openvpn/ta.key 0"

option duplicate_cn 1

option server "192.168.30.0 255.255.255.0"
option topology subnet
list push "topology subnet"
list push "redirect-gateway def1 bypass-dhcp"

list push "route 192.168.20.0 255.255.255.0"
list push "dhcp-option DNS 192.168.20.1"
list push "dhcp-option DOMAIN lan"

option client_to_client 1
option keepalive "10 120"
option comp_lzo yes
option persist_key 1
option persist_tun 1
option user nobody
option group nogroup

option status /tmp/openvpn-status.log
option log /tmp/openvpn.log
option verb 6
option mute 20

Contents of the /etc/openvpn directory:

root@tm02:/etc/openvpn# ls -al
drwxr-xr-x 2 root root 0 Mar 24 21:43 .
drwxr-xr-x 1 root root 0 Jan 27 20:34 ..
-rw-r--r-- 1 root root 1184 Mar 24 21:42 ca.crt
-rw-r--r-- 1 root root 479 Mar 24 21:42 crl.pem
-rw-r--r-- 1 root root 156 Mar 24 21:42 dh512.pem
-rw-r--r-- 1 root root 3395 Mar 24 21:42 server.crt
-rw------- 1 root root 522 Mar 24 21:42 server.key
-rw------- 1 root root 636 Mar 24 21:43 ta.key


_________________
HP T5730 - AMD Turion 64 x2 Dual-Core 2.4GHz CPU
(TMDTL68HAX5DM)
320GB WD 2.5" H.D. / 2GB RAM
(Windows 8.1 Pro 64-bit)
EVGA GeForce 7600 GT PCIe x16 card, (in x1 speed)
New 12vdc 16 amp (192w) PSU
Back to top
View user's profile Send private message
momo
Dan Should Pay Me


Joined: 26 Aug 2008
Posts: 541

PostPosted: Sat Mar 26, 2016 1:39 pm    Post subject: The Internet is a strange place Reply with quote

OK... It's that time again ... to have another public talk about recent events.. Smile

Is it really ME, that seems to make people visiting here angry for some reason,
that they just don't want to come back?

It seems our latest visitor 985ach has decided to abandon this thread.

I've sent a PM to him mentioning the OpenWRT members post about the VPN settings that worked,
but even though I saw he read the PM, he hasn't replied to it, or here in the thread.

I truly have NO IDEA what I apparently did to deserve his hatred of me,
to the point he's not even replying anymore, to any of my communications,
when seemingly, just a few days earlier, everything seemed fine.

I never forced him to test the router, and even stated to him it's no rush to work on it, but ...
I'm getting the blame for something that I have no idea what he's mad at.

Well...I'm telling you all...I'm fed-UP with all this internet crap,
and everyone's mental hissy-fits against me..!

It's gotten to no longer be fun to stay here, ... and so...I'm leaving.

Maybe for a short while, but maybe forever...I don't know yet.
Because I'm sure, eventually...there will be another internet 'lunatic' with issues that get blamed on me.

I may even delete this entire thread...
so gather-up any info you like here, and save it to your own hard drives
or flash drives, or write it on your ass.
Because it may not be here for much longer.

I'm done...!!!

If anyone wants to make a comment about it...go ahead...maybe I'll read it.
If I even come back here at all.
_________________
HP T5730 - AMD Turion 64 x2 Dual-Core 2.4GHz CPU
(TMDTL68HAX5DM)
320GB WD 2.5" H.D. / 2GB RAM
(Windows 8.1 Pro 64-bit)
EVGA GeForce 7600 GT PCIe x16 card, (in x1 speed)
New 12vdc 16 amp (192w) PSU
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Mon Mar 28, 2016 8:12 am    Post subject: Reply with quote

Waaaaaaaaaaaaaaahoooooooooooooo! XD

[next day update]

Just doing some network cable runs this morning / today but I do have my HooToo here with me, I've also got my dd-wrt router here too (hopefully I'll have a power supply for it here too)

play times!
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
985ach
MagicJack Expert


Joined: 05 Nov 2014
Posts: 83
Location: England

PostPosted: Fri Apr 01, 2016 7:14 am    Post subject: Reply with quote

managed to finish copying all the configs over onto the hootoo today and changing the required to sui tmy network

I found somewhere in this part:
Code:
/etc/config/system

config system
option hostname 'tm02'
option zonename 'UTC'
option timezone 'GMT0'
option conloglevel '8'
option cronloglevel '8'

config timeserver 'ntp'
option enabled '1'
list server 'ntp1.npl.co.uk'
list server 'ntp2.npl.co.uk'
list server '0.uk.pool.ntp.org'
list server '1.uk.pool.ntp.org'
list server '2.uk.pool.ntp.org'
list server '3.uk.pool.ntp.org'

config led 'led_eth'
option name 'Ethernet'
option sysfs 'ht-tm02:green:lan'
option dev 'eth0'
option trigger 'netdev'
option mode 'link tx rx'

config led 'led_wifi_led'
option name 'wifi'
option sysfs 'ht-tm02:blue:wlan'
option dev 'wlan0'
option trigger 'netdev'
option mode 'link tx rx'


cuase a problem loading pages in the LuCI GUI

but I removed these two enteries
Code:
list server 'ntp1.npl.co.uk'
list server 'ntp2.npl.co.uk'


reboots and everything appears to be decent - doesn't appear to be a log file generated by openvpn (it was while the above two likes were still added)

now it just needs hooking up to the home network (hopefully it won't act as the gateway / dhcp server for eveything on the home network, it doesn't look like it would) then try connecting to it from an external source
_________________
985ach. // ash
HP T5730
AMD Turion TL60 2GHz (TMDTL60HAX5DM)
2GB RAM / 128GB SATA SSD
Windows 7 64b
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    magicJack and MagicJack Plus Support, Reviews, FAQs and Hacks Forum Index -> Using magicJack on a Thin Client All times are GMT - 4 Hours
Goto page Previous  1, 2, 3 ... 46, 47, 48, 49  Next
Page 47 of 49

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB Turbo Extended Edition © 2013, phpBB Group
magicJack and magicJack Plus are trademarks of magicJack LLP. This website is in no way affiliated, endorsed, or sponsored by magicJack LLP, and is an unofficial forum for consumers to openly communicate regarding their experiences with the magicJack products.